laravel5.5项目初始构建

开发环境

系统:winows8
php版本:php7.1
IDE:phpstorm
laravel版本:5.5

laragon集成环境的安装

请参考:laragon集成环境的安装

使用laravel-admin包方便后台开发

参考文档:laravel-admin中文文档
1.安装依赖

1
composer require encore/laravel-admin "1.5.*"

2.发布资源

1
php artisan vendor:publish --provider="Encore\Admin\AdminServiceProvider"

3.完成安装

1
php artisan admin:install

laravel5在phpstorm内的代码提示工具

请参考:为PhpStorm添加Laravel 代码智能提示功能